[NEW] Install HaarpCache v1.5.1 and Haarp-Viewer v1.1 from a Bash Script

ChangeLog (of HaarpCache v1.5.1):

* Fix problem: “segfault at 10 ip 000000000042ee66 sp 00007fffb74d2270 error 4 in haarp[400000+45000]”.
* Manager of multiples ip for the header “X-forwarded-for”.
* Update bash script of installation: force the redirect to haarp from squid in squid.conf.


Reinstalación: https://github.com/keikurono/haarpcache#reinstall-or-update

Instalación con el script:

su
coloque su password root.

wget https://raw.githubusercontent.com/keikurono/haarpcache/master/installHaarp.sh
chmod +x installHaarp.sh
bash installHaarp.sh

Next. next …:

Configuración del HaarpCache paralelo con MikroTik:

topo_haarp
Reglas de ruteo con MikroTik:

/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.0.4.10 routing-mark=haarp_route scope=30 target-scope=10
/ip firewall mangle
add action=mark-routing chain=prerouting comment="== Haarp - Mangle ==" disabled=no dst-port=80 in-interface=LAN new-routing-mark=haarp_route passthrough=no protocol=tcp
add action=mark-connection chain=forward comment="== HAARPCACHE ==" content="X-Cache: HIT from Haarp" disabled=no new-connection-mark=haarp-connection passthrough=yes
add action=mark-packet chain=forward connection-mark=haarp-connection disabled=no new-packet-mark=haarp-packs passthrough=no
add action=mark-connection chain=forward comment="==SQUID - TOS 8==" disabled=no dscp=2 new-connection-mark=squid-connection passthrough=yes
add action=mark-packet chain=forward connection-mark=squid-connection disabled=no new-packet-mark=squid-packs passthrough=yes
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=4M name="HaarpCache" packet-mark=haarp-packs parent=global-out priority=4 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=4M name="Squid 3.x" packet-mark=squid-packs parent=global-out priority=4 queue=default

Fuente: http://www.alterserv.com/foros/index.php?topic=532.0

Si utiliza este modo paralelo con mikrotik, agregar al inicio del archivo ‘/etc/squid3/squid.conf’, lo siguiente:

acl localnet src 192.0.3.0/24

Cambiar ‘192.0.3.0/24’ por la de su red correspondiente.
Ejecute:

sudo service squid3 restart

HaarpViewer:

hviewer1

Notas:
*El script de instalación es funcional para sistemas Debian/Ubuntu. Está probado en Ubuntu Server 14.04 y Debian 7.x
*No es necesario reinstalar todo el sistema Debian/Ubuntu!.

Saludos!.

Post a comment or leave a trackback: Trackback URL.

Comentarios

  • ALONSO  On 22 septiembre, 2015 at 1:54 pm

    AMIGO MUY BUEN APORTE, NOS FALTARIA PARA LOS QUE NO SABEMOS TANTO, SOBRE LAS FUNCIONALIDADES DE ESTE SISTEMA DE CACHEO.

    • Anónimo  On 22 septiembre, 2015 at 5:24 pm

      Multidisco con cache a 100 paginas de videos/juegos/imagenes.
      Puedes instalarlo en cualquier server Linux. Debian, Centos, Ubuntu ArchLinux etc.
      La funcionalidad es union de partes de video en uno sólo, cacheo html5, youtube etc.

  • CardLost  On 25 septiembre, 2015 at 8:55 pm

    Interesante amigo déjame probarlo!!..

  • Anónimo  On 27 septiembre, 2015 at 10:15 am

    Buenos días, cual es la contraseña del servidor de la base de datos mysql al momento de la instalación…?

  • carlos Grandi  On 27 septiembre, 2015 at 12:48 pm

    Idem anterior… cual es la contraseña del servidor de la base de datos mysql al momento de la instalación…?

    • Anónimo  On 27 septiembre, 2015 at 2:41 pm

      No hay una contraseña predeterminada, pueden ser alguna que ya hayan colocado o la que colocaron cuando instalaron el mysql-server.

      En caso de haber instalado anteriormente el raptorcache entonces es ‘raptor’.

  • Marin  On 28 septiembre, 2015 at 1:05 am

    Buenas noches, como puedo comprobar que este funcionando? lo tengo instalado junto con pfsense. Gracias.-

    • keikurono01  On 28 septiembre, 2015 at 10:31 am

      Por el haarpviewer como se muestra en la imagen de arriba.
      Debes tener esos ‘rayos’ en amarillo para comprobar que esta haciendo cache.
      Otra forma es via consola: “ps aux | grep haarp” notaras varios threads disponibles del haarp (ON).

  • Rach3  On 28 septiembre, 2015 at 5:27 pm

    Felicitaciones!!!, es excelente el trabajo que has realizado, y el hecho de dejarlo libre para el uso de cualquiera es un gran gesto.

    Saludos

  • ehcoma  On 30 septiembre, 2015 at 1:34 pm

    Como hago para instalar otro hd de cache, el programa esta funcionando perfectamente…??

    • keikurono01  On 30 septiembre, 2015 at 7:52 pm

      Claro que sí esta funcional.
      Puedes montar tu disco en el sistema?.
      Puedes encontrar muchos manuales de como formatear y montar discos nuevos en el linux/ubuntu o debian.
      Luego de esto agrega el directorio montado al CACHEDIR de /etc/haarp/haarp.conf. Asi: CACHEDIR /disco1/|/disco2/ .. | …
      donde disco1 y disco2 … son los directorios donde los HD son montados.
      Reinicias el squid y haarp y listo.
      Saludos.

  • ehcoma  On 2 octubre, 2015 at 7:54 am

    Buen dia , el haarp hace cache a las actualizaciones de dota2…???

    • Anónimo  On 2 octubre, 2015 at 10:58 pm

      Ahora no, pero si deseas ese plugin o algo urgente con el haarp, podemos hablarlo en forma privada – email: kei.haarpcache@gmail.com

      keikurono.

  • ehcoma  On 2 octubre, 2015 at 1:11 pm

    Que es lo que hace esta regla en el crontab…???

  • ehcoma  On 2 octubre, 2015 at 1:12 pm

    Que hace esta regla en contrab…???
    0 */1 * * * root /etc/init.d/haarpclean

    • Anónimo  On 2 octubre, 2015 at 10:54 pm

      Limpia el cache cada hora. Si esta lleno el disco o sobrepasa el umbral configurado en el haarp.conf.

  • Julio César Gutierrez Natera  On 30 octubre, 2015 at 9:00 am

    Excelente lo acabo de instalar estoy probando..

  • Anónimo  On 31 octubre, 2015 at 1:36 am

    Cuando te pide colocar el password de mysql, cual debo colocar?

    • keikurono01  On 31 octubre, 2015 at 9:00 am

      Cualquiera .. pero, recuerda cual fue la clave que colocaste cuando lo instalaste por primera vez .. .si tienes raptor, entonces es ‘raptor’.

  • Jesus  On 4 febrero, 2016 at 8:52 pm

    tengo una consulta, para ponerlo en forma transparente no hay que hacer un archivo que limpie las ip tables con en raptor?, hago la pregunta porque en el archivo rc.local veo que tiene los comandos de las ip tables
    gracias

  • Jesus  On 5 febrero, 2016 at 1:38 pm

    he utilizado este comando tail -f /var/log/squid3/error.log y veo que el error log continua creciendo, esto esta correcto lo digo porque no veo que me hace cache de youtube ni facebook, por otro lado lo tengo el haarp configurado de forma transparente, la pregunta es no hay que crear un archivo para limpiar las ip tables?
    he visto esto en otros servidores cache como en raptor cache que se utilza un archivo fw.sh para limpiar las ip tables.

    mi pregunta es porque en el haarpviewer casi no veo movimiento y el icono en forma de rayo no esta de color amarillo, los iconos de youtube no estan en 100%

    • keikurono01  On 6 febrero, 2016 at 9:57 am

      Haarp no hace cache de HTTPS (Facebook, Twitter, Instagram, etc). Desde hace poco tampoco de Youtube.

  • victor  On 5 septiembre, 2016 at 11:35 am

    saludos esta caido el link.. talves alguno nuevo estaba yendo a instalar gracias.

  • DAVID HUIX ARQUES  On 13 octubre, 2016 at 10:08 am

    Ya lo instale 2 veces tal como se indica en el tutorial pero al accedes al panel http://192.0.4.10:88/cgi-bin/haarp.cgi me sale la pantalla totalmente gris no me dice nada. Que estoy haciendo mal? gracias de ante mano

Trackbacks

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: