NEW RELEASE: HaarpCache v1.5.3-rcx

Pueden seguir los avances del sistema en el Grupo de desarrolladores interesados en el projecto HaarpCache o Forks de ThunderCache 3.1.

+¿Cambios urgentes o mantenimiento del sistema?, escríbame a:
kei.haarpcache(at)gmail.com

Nota: Instalación paralelo a Mikrotik (con SCRIPT)

HaarpCache Sistema de almacenamiento en caché automático de dominios dinámicos.

HaarpCache es un fork de ThunderCache 3.1 que en comparación a otros caches es un cache inteligente en el sentido del almacenamiento y en el despacho de archivos. Es decir almacena cada pedazo del vídeo o archivo juntándolos todo en un único recurso en el disco, aún sin importar si estas llegaron completas o no.
Con ello, el HaarpCache puede despachar incluso cuando se piden partes de un archivo que en mayor tamaño está en cache. En conclusión HaarpCache da soporte a la tecnología MPEG-DASH.

▓ ChangeLog ▓:

  • Update plugins: Youtube and Friv.
  • New Plugin: Steam/Games.
  • Update Script of installation.

Para el funcionamiento del Youtube.com, agregar las siguientes lineas en squid.conf:

acl google url_regex -i (googlevideo.com|www.youtube.com) acl iphone browser -i regexp (iPhone|iPad) acl BB browser -i regexp (BlackBerry|PlayBook) acl Winphone browser -i regexp (Windows.*Phone|Trident|IEMobile) acl Android browser -i regexp Android request_header_access User-Agent deny google !iphone !BB !Winphone !Android request_header_replace User-Agent Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)

Estas mantienen las conexiones HTTP en Youtube.com. Este artificio sólo funciona para PC’s.

El cache sólo trabaja en HTTP.

Manual de instalación: http://keikurono.github.io/haarpcache/#installing
Manual de reinstalación: http://keikurono.github.io/haarpcache/#reinstall-or-update
Manual de instalación del Haarp-Viewer: http://keikurono.github.io/haarp-viewer/

Para capturar/observar las IP de sus clientes que hacen uso del HaarpCache, editar la opción ‘FORWARDED_IP false’ a ‘FORWARDED_IP true’ en el haarp.conf 

Captura – HaarpViewer:
dota2
Lista de plugins soportados:


Youtube (https not supported), Netflix (Video and Images), DoubleClick (Block of ADS), Googlevideo, Dailymotion, AOL, Vimeo, Metacafe, Modovideo, Bitgravity, Globo, Terra, Viddler, Justin, Edgecastcdn, Youku, Wrzuta, 5min, Viddler, Tumblr, Facebook (https not supported);

Bomusica, Bullafina, Coqui, Cutmu, Domusica, Domusicas, Dungeonbusters, Goobeo, Gooveo, Miniclip, Molenillo, Mp3-Buscador, Musicaveo, Ning, Nofeehost, Sonicomusica, Turner, Vevos;

4shared, Mediafire, Etrustdownloads, Ziddu;

Akamaihd, Amazonaws, Blogspot, Imageshack, Issuu, Mercadolibre, Submanga, Ytimg;

Avast, Avgate, Eset, Mcafee, Avira, Bitdefender;

Windowsupdate, Adobe;

Porntube, Xvideos,
Pornhub, Redtube, YouPorn, Serviporno, Tube8;

Appspot, Cloudfront, Juegosdiarios, Juegosjuegos, Netpocket, Nordeus, Popcap, Socialpointgames, Telaxo, Tetrisfb, Steam, Vostucdn, Wooga, Zgncdn;

Disneylatino, Friv, Geewa, Hulkshare, Kixeye, Llnwd, Maguinamotors, Manabar;

SpeedTest.


Anuncios

NEW RELEASE: HaarpCache v1.5.2-rcx and Haarp-Viewer v1.1.1

Pueden seguir los avances del sistema en el Grupo de desarrolladores interesados en el projecto HaarpCache o Forks de ThunderCache 3.1.

+¿Cambios urgentes o mantenimiento del sistema?, escríbame a:
kei.haarpcache(at)gmail.com

Nota: Instala todo con un SCRIPT+Mikrotik Config

HaarpCache Sistema de almacenamiento en caché automático de dominios dinámicos.

HaarpCache es un fork de ThunderCache 3.1 que en comparación a otros caches es un cache inteligente en el sentido del almacenamiento y en el despacho de archivos. Es decir almacena cada pedazo del vídeo o archivo juntándolos todo en un único recurso en el disco, aún sin importar si estas llegaron completas o no.
Con ello, el HaarpCache puede despachar incluso cuando se piden partes de un archivo que en mayor tamaño está en cache. En conclusión HaarpCache da soporte a la tecnología MPEG-DASH.

▓ ChangeLog ▓:

  • Fix problem in the mechanism of removal of files in the db
    (06/10/15) (v1.5.2-rc4) — Important Update! —

  • Save the first IP of the ‘X-Forwarded-For’ header (04/10/15) (v1.5.2-rc3).
  • Update script of installation for dowload the last version of haarpcache and haarp-viewer (v1.5.2-rc2).
  • Fix problem in the process of cleaned of the cache (v1.5.2-rc1).

  • Add by default the webaccess log for haarpviewer in haarp.conf (v1.5.2-rc1).

Para el funcionamiento del Youtube.com, agregar las siguientes lineas en squid.conf:

acl google url_regex -i (googlevideo.com|www.youtube.com) acl iphone browser -i regexp (iPhone|iPad) acl BB browser -i regexp (BlackBerry|PlayBook) acl Winphone browser -i regexp (Windows.*Phone|Trident|IEMobile) acl Android browser -i regexp Android request_header_access User-Agent deny google !iphone !BB !Winphone !Android request_header_replace User-Agent Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)

Estas mantienen las conexiones HTTP en Youtube.com. Este artificio sólo funciona para PC’s.

El cache sólo trabaja en HTTP.

Manual de instalación: http://keikurono.github.io/haarpcache/#installing
Manual de reinstalación: http://keikurono.github.io/haarpcache/#reinstall-or-update
Manual de instalación del Haarp-Viewer: http://keikurono.github.io/haarp-viewer/

Para capturar/observar las IP de sus clientes que hacen uso del HaarpCache, editar la opción ‘FORWARDED_IP false’ a ‘FORWARDED_IP true’ en el haarp.conf 

Lista de plugins soportados:


Youtube (https not supported), Netflix (Video and Images), DoubleClick (Block of ADS), Googlevideo, Dailymotion, AOL, Vimeo, Metacafe, Modovideo, Bitgravity, Globo, Terra, Viddler, Justin, Edgecastcdn, Youku, Wrzuta, 5min, Viddler, Tumblr, Facebook (https not supported);

Bomusica, Bullafina, Coqui, Cutmu, Domusica, Domusicas, Dungeonbusters, Goobeo, Gooveo, Miniclip, Molenillo, Mp3-Buscador, Musicaveo, Ning, Nofeehost, Sonicomusica, Turner, Vevos;

4shared, Mediafire, Etrustdownloads, Ziddu;

Akamaihd, Amazonaws, Blogspot, Imageshack, Issuu, Mercadolibre, Submanga, Ytimg;

Avast, Avgate, Eset, Mcafee, Avira, Bitdefender;

Windowsupdate, Adobe;

Porntube, Xvideos,
Pornhub, Redtube, YouPorn, Serviporno, Tube8;

Appspot, Cloudfront, Juegosdiarios, Juegosjuegos, Netpocket, Nordeus, Popcap, Socialpointgames, Telaxo, Tetrisfb, Vostucdn, Wooga, Zgncdn;

Disneylatino, Friv, Geewa, Hulkshare, Kixeye, Llnwd, Maguinamotors, Manabar;

SpeedTest.


[NEW] Install HaarpCache v1.5.1 and Haarp-Viewer v1.1 from a Bash Script

ChangeLog (of HaarpCache v1.5.1):

* Fix problem: “segfault at 10 ip 000000000042ee66 sp 00007fffb74d2270 error 4 in haarp[400000+45000]”.
* Manager of multiples ip for the header “X-forwarded-for”.
* Update bash script of installation: force the redirect to haarp from squid in squid.conf.


Reinstalación: https://github.com/keikurono/haarpcache#reinstall-or-update

Instalación con el script:

su
coloque su password root.

wget https://raw.githubusercontent.com/keikurono/haarpcache/master/installHaarp.sh
chmod +x installHaarp.sh
bash installHaarp.sh

Next. next …:

Configuración del HaarpCache paralelo con MikroTik:

topo_haarp
Reglas de ruteo con MikroTik:

/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.0.4.10 routing-mark=haarp_route scope=30 target-scope=10
/ip firewall mangle
add action=mark-routing chain=prerouting comment="== Haarp - Mangle ==" disabled=no dst-port=80 in-interface=LAN new-routing-mark=haarp_route passthrough=no protocol=tcp
add action=mark-connection chain=forward comment="== HAARPCACHE ==" content="X-Cache: HIT from Haarp" disabled=no new-connection-mark=haarp-connection passthrough=yes
add action=mark-packet chain=forward connection-mark=haarp-connection disabled=no new-packet-mark=haarp-packs passthrough=no
add action=mark-connection chain=forward comment="==SQUID - TOS 8==" disabled=no dscp=2 new-connection-mark=squid-connection passthrough=yes
add action=mark-packet chain=forward connection-mark=squid-connection disabled=no new-packet-mark=squid-packs passthrough=yes
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=4M name="HaarpCache" packet-mark=haarp-packs parent=global-out priority=4 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=4M name="Squid 3.x" packet-mark=squid-packs parent=global-out priority=4 queue=default

Fuente: http://www.alterserv.com/foros/index.php?topic=532.0

Si utiliza este modo paralelo con mikrotik, agregar al inicio del archivo ‘/etc/squid3/squid.conf’, lo siguiente:

acl localnet src 192.0.3.0/24

Cambiar ‘192.0.3.0/24’ por la de su red correspondiente.
Ejecute:

sudo service squid3 restart

HaarpViewer:

hviewer1

Notas:
*El script de instalación es funcional para sistemas Debian/Ubuntu. Está probado en Ubuntu Server 14.04 y Debian 7.x
*No es necesario reinstalar todo el sistema Debian/Ubuntu!.

Saludos!.

Sigue leyendo

NEW RELEASE: HaarpCache v1.5 and Haarp-Viewer v1.1

Pueden seguir los avances del sistema en el Grupo de desarrolladores interesados en el projecto HaarpCache o Forks de ThunderCache 3.1.

+¿Cambios personalizados?, escribir a+
kei.haarpcache(at)gmail.com

New: Instalar todo en un SCRIPT+Mikrotik Config

HaarpCache Sistema de almacenamiento en caché automático de dominios dinámicos.

Info: HaarpCache es un fork de ThunderCache 3.1 que en comparación a otros caches es un cache inteligente en el sentido del almacenamiento y en el despacho de archivos. Es decir almacena cada pedazo del vídeo o archivo juntándolos todo en un único recurso en el disco, aún sin importar si estas llegaron completas o no.
Con ello, el HaarpCache puede despachar incluso cuando se piden partes de un archivo que en mayor tamaño está en cache. En conclusión HaarpCache da soporte a la tecnología MPEG-DASH.

▓ ChangeLog ▓:

  • Storing the address IP of the user who uses the cache.
  • Adding user history for each file in cache.
  • Update regex for support of the oglobo domain.
  • By default, the 75% of the hard disk is used.

Para el funcionamiento del Youtube.com, agregar las siguientes lineas en squid.conf:

acl google url_regex -i (googlevideo.com|www.youtube.com) acl iphone browser -i regexp (iPhone|iPad) acl BB browser -i regexp (BlackBerry|PlayBook) acl Winphone browser -i regexp (Windows.*Phone|Trident|IEMobile) acl Android browser -i regexp Android request_header_access User-Agent deny google !iphone !BB !Winphone !Android request_header_replace User-Agent Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)

Estas mantienen las conexiones HTTP en Youtube.com. Este artificio sólo funciona para PC’s.

El cache sólo trabaja en HTTP.

Manual de instalación: http://keikurono.github.io/haarpcache/#installing
Manual de reinstalación: http://keikurono.github.io/haarpcache/#reinstall-or-update
Manual de instalación del Haarp-Viewer: http://keikurono.github.io/haarp-viewer/

Para capturar/observar las IP de sus clientes que hacen uso del HaarpCache, editar la opción ‘FORWARDED_IP false’ a ‘FORWARDED_IP true’ en el haarp.conf .

Igualmente, adicionar la linea: request_header_access X-Forwarded-For deny !haarp_lst, al final de su squid.conf.

Capturas del HaarpCache con Haarp-Viewer v1.1:

Estadísticas e historial por días de cada Domino.

Estadísticas e historial por días de cada Domino.

Archivos usados en Cache.

Archivos usados en Cache.

Historial de usuarios que hicieron uso de un archivo en Cache.

Historial de usuarios que hicieron uso de un archivo en Cache.


Lista de plugins soportados:


Youtube (https not supported), Netflix (Video and Images), DoubleClick (Block of ADS), Googlevideo, Dailymotion, AOL, Vimeo, Metacafe, Modovideo, Bitgravity, Globo, Terra, Viddler, Justin, Edgecastcdn, Youku, Wrzuta, 5min, Viddler, Tumblr, Facebook (https not supported);

Bomusica, Bullafina, Coqui, Cutmu, Domusica, Domusicas, Dungeonbusters, Goobeo, Gooveo, Miniclip, Molenillo, Mp3-Buscador, Musicaveo, Ning, Nofeehost, Sonicomusica, Turner, Vevos;

4shared, Mediafire, Etrustdownloads, Ziddu;

Akamaihd, Amazonaws, Blogspot, Imageshack, Issuu, Mercadolibre, Submanga, Ytimg;

Avast, Avgate, Eset, Mcafee, Avira, Bitdefender;

Windowsupdate, Adobe;

Porntube, Xvideos,
Pornhub, Redtube, YouPorn, Serviporno, Tube8;

Appspot, Cloudfront, Juegosdiarios, Juegosjuegos, Netpocket, Nordeus, Popcap, Socialpointgames, Telaxo, Tetrisfb, Vostucdn, Wooga, Zgncdn;

Disneylatino, Friv, Geewa, Hulkshare, Kixeye, Llnwd, Maguinamotors, Manabar;

SpeedTest.


NEW RELEASE: HAARPCACHE v1.4.1

Pueden seguir los avances del sistema en el Grupo de desarrolladores interesados en el projecto HaarpCache o Forks de ThunderCache 3.1.

+Para plugins personalizados escríbame a+
kei.haarpcache(at)gmail.com

Hola espero disfruten esta nueva versión.

Changelog:

  • NEW: Update regex for support of the oglobo domain (07/08/15).
  • Update the plugins for edgecastcdn, socialpointgames and akamaihd.
  • Update plugin of Youtube: not cached of videos on live.
  • Using the parameter ‘clen’ of the url from youtube as file size.
  • Update the HaarpClean program.
  • Fixed the problem of bad replacement string in the SQL requests.
  • Update the file of configuration for logrotate.
  • Fix problem: ‘general protection ip:7f39b6cdd44e sp:7ffc278771f0 error:0 in libmysqlclient.so.18.0.0‘.

Se agradecen las pruebas hechas por: Hernan Dario Nacimiento.

Para el funcionamiento del Youtube.com, agregar las siguientes lineas en squid.conf:

acl google url_regex -i (googlevideo.com|www.youtube.com) acl iphone browser -i regexp (iPhone|iPad) acl BB browser -i regexp (BlackBerry|PlayBook) acl Winphone browser -i regexp (Windows.*Phone|Trident|IEMobile) acl Android browser -i regexp Android request_header_access User-Agent deny google !iphone !BB !Winphone !Android request_header_replace User-Agent Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)

Estas mantienen las conexiones HTTP en Youtube.com. Este artificio sólo funciona para PC’s.

El cache sólo trabaja en HTTP.

Manual de instalación/reinstalación: http://keikurono.github.io/haarpcache/

Capturas y resultados:

 Lista de plugins soportados:


Youtube (https not supported), Netflix (Video and Images), DoubleClick (Block of ADS), Googlevideo, Dailymotion, AOL, Vimeo, Metacafe, Modovideo, Bitgravity, Globo, Terra, Viddler, Justin, Edgecastcdn, Youku, Wrzuta, 5min, Viddler, Tumblr, Facebook (https not supported);

Bomusica, Bullafina, Coqui, Cutmu, Domusica, Domusicas, Dungeonbusters, Goobeo, Gooveo, Miniclip, Molenillo, Mp3-Buscador, Musicaveo, Ning, Nofeehost, Sonicomusica, Turner, Vevos;

4shared, Mediafire, Etrustdownloads, Ziddu;

Akamaihd, Amazonaws, Blogspot, Imageshack, Issuu, Mercadolibre, Submanga, Ytimg;

Avast, Avgate, Eset, Mcafee, Avira, Bitdefender;

Windowsupdate, Adobe;

Porntube, Xvideos,
Pornhub, Redtube, YouPorn, Serviporno, Tube8;

Appspot, Cloudfront, Juegosdiarios, Juegosjuegos, Netpocket, Nordeus, Popcap, Socialpointgames, Telaxo, Tetrisfb, Vostucdn, Wooga, Zgncdn;

Disneylatino, Friv, Geewa, Hulkshare, Kixeye, Llnwd, Maguinamotors, Manabar;

SpeedTest.


NEW RELEASE: HAARPCACHE v1.4.0

Pueden seguir los avances del sistema en el Grupo de desarrolladores interesados en el projecto HaarpCache o Forks de ThunderCache 3.1.

+Para plugins personalizados escríbame a+
kei.haarpcache(at)gmail.com

* Update 2015/07/25: Update plugin of Youtube, not cached videos on live.
* Update 2015/07/21: Fixed the problem of bad replacement string in the SQL requests.
* Update 2015/07/08: Update the HaarpClean program.

Hola espero disfruten esta nueva versión.
Changelog:

  • 50 New Plugins.
  • Improved support for DASH technology.
  • Update the file of configuration for logrotate.
  • Fix problem: ‘Error in /usr/local/sbin/haarp: free(): invalid pointer: 0x00007fb5e166d618‘.

Para el funcionamiento del Youtube.com, agregar las siguientes lineas en squid.conf:

acl google url_regex -i (googlevideo.com|www.youtube.com) acl iphone browser -i regexp (iPhone|iPad) acl BB browser -i regexp (BlackBerry|PlayBook) acl Winphone browser -i regexp (Windows.*Phone|Trident|IEMobile) acl Android browser -i regexp Android request_header_access User-Agent deny google !iphone !BB !Winphone !Android request_header_replace User-Agent Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)

Estas mantienen las conexiones HTTP en Youtube.com. Este artificio sólo funciona para PC’s.

El cache sólo trabaja en HTTP.

Manual de instalación/reinstalación: http://keikurono.github.io/haarpcache/

Capturas y resultados:

 Lista de plugins soportados:


Youtube (https not supported), Netflix (Video and Images), DoubleClick (Block of ADS), Googlevideo, Dailymotion, AOL, Vimeo, Metacafe, Modovideo, Bitgravity, Globo, Terra, Viddler, Justin, Edgecastcdn, Youku, Wrzuta, 5min, Viddler, Tumblr, Facebook (https not supported);

Bomusica, Bullafina, Coqui, Cutmu, Domusica, Domusicas, Dungeonbusters, Goobeo, Gooveo, Miniclip, Molenillo, Mp3-Buscador, Musicaveo, Ning, Nofeehost, Sonicomusica, Turner, Vevos;

4shared, Mediafire, Etrustdownloads, Ziddu;

Akamaihd, Amazonaws, Blogspot, Imageshack, Issuu, Mercadolibre, Submanga, Ytimg;

Avast, Avgate, Eset, Mcafee, Avira, Bitdefender;

Windowsupdate, Adobe;

Porntube, Xvideos,
Pornhub, Redtube, YouPorn, Serviporno, Tube8;

Appspot, Cloudfront, Juegosdiarios, Juegosjuegos, Netpocket, Nordeus, Popcap, Socialpointgames, Telaxo, Tetrisfb, Vostucdn, Wooga, Zgncdn;

Disneylatino, Friv, Geewa, Hulkshare, Kixeye, Llnwd, Maguinamotors, Manabar;

SpeedTest.